phpbar.de logo

Mailinglisten-Archive

Zur Volltextsuche
 
[php] PHPMyAdmin / Authentification-Problem

[php] PHPMyAdmin / Authentification-Problem

Wesley Crusher ceo_(at)_webprovideyou.de
Fri, 2 Mar 2001 16:09:12 +0100


Hi Ihrs,

folgendes Problem:

Auf meinem Server rennt PHPMyAdmin mit einer Advanced Authentification. 

Wenn man nun sich das erste mal einloggt, dann geht alles wunderbar, man kommt
in PHPMyAdmin rein und alles funzt. Wenn man jetzt mal auf die Idee kommt, auf
Logout zu klicklen um sichg neu einzuloggen passiert das:

	- Es kommt wieder die HTTP-Authentifizierungs-Anfrage (was ja auch soll)
 	- man tippt wieder User und Passwort ein - so wie beim ersten mal...
	- Der Dialog kommt wieder und wieder und man kommt nicht mehr rein
	- Erst wenn man einmal den Dialog ganz leer läßt - und den bereits
voreingetragenen "Ex"-User löscht und dann beim nochmaligen erscheinen des
Dialogs die Daten einträgt kommt man wieder rein.

Nur das Ausloggen-Freilassen-Einloggen is ja nun nicht ganz Sinn und Zweck des
ganzen ;)

IMHO gibts hier nen Fehler mit PHP/Browser/HTTP-Auth - denn wenn ich den
Browser schliess dann gehts wieder - (nein es is kein Cookie-Prob weil kein
Cookie angelegt wird...wär ja noch schöner ich und Cookies *kopfschüttel*)

Kennt jemand des Prob und hat nen Fix? Oder muss ich mir echt ne eigene
Authentifizierung schreiben? ;)

Bye Ihrs

Wesley
mailto:wesley_(at)_openthesource.de




 

php::bar PHP Wiki   -   Deutschsprachige Mailinglisten   -   Listenarchive   -   Volltextsuche